[Samba] Samba 3.0.5 cannot mount Windows 2003 shares

Tomasz Dabrowski Tomasz.Dabrowski at wl.sggw.waw.pl
Wed Oct 6 17:52:05 GMT 2004

I have kernel 2.4.20-31.9smp, samba-3.0.7-1 and redhat linux
and I have a problem like as
I'm having a real hair-raising problem here and I thought maybe someone 
could help.  At least I hope so.

My workstation was running 3.0.2a, upgraded to 3.0.5.  After upgrading 
to 3.0.5, I can no longer mount shares on my 2003 server.  This started 
happening on an upgrade to 3.0.4 as well, I might add.

Permissions-wise: I own the directory mounts on the local Linux 
workstation, directories are set 755.

When I try to mount with smbfs via an fstab entry:

//kitanah/home /mnt/kitanah/home smbfs 
0 0

...nautilus crashes and all attempts to "ls" the mounted directory 
result in "ls: permission denied."  Also, I can no longer work with the 
directory or unmount it until I reboot.

I've also tried the fstab line above, substituting smbfs for cifs and I 
get "missing or invalid username," despite the fact that 
/etc/credentials is in the format:


cifs also fails with the same error if I try to do a "mount -t cifs 
yadda yadda".

I have SMB signing disabled on the 2003 server and this was working fine 
until the upgrade to 3.0.4 and now 3.0.5.  I've spent the better part of 
two days trying to figure out what's going on, but cannot unravel it. 
Can anyone here give me some pointers on what I can check?

Thanks in advance.

sorry, my english is poor

More information about the samba mailing list