[Samba] smbmount ignores uid option

Manuel Weinzierl mweinzierl at konplan.com
Tue Oct 5 16:22:36 GMT 2004

Hi all,

I have nearly the same problem with an actual SuSE 9.1 (Pro) distribution. Older releases (SuSE 8.1/8.2/9.0 Pro) are working as expected with the correct UID/GID. These distriburtions are based on samba 2.x clients - with 9.1 SuSE switched to a samba 3.x client.

With SUSE 9.1 I tried the following alternatives mounting a samba share as an "normal" user (the server is a samba 3.x linux host):
"sudo mount -t smbfs -o username=smbuser,password=smbpwd,uid=1000,gid=100 //server/share ~/mountpoint"
"sudo smbmount //server/share ./mountpoint -o uid=1000,gid=100,username=smbuser,password=smbpwd"
on the older distros I simply set the SUID bit of "smbmnt" and "smbumount", so mounting as an user like described in the example above works without calling "sudo".

I tried the alternatives from above with
- samba 3.0.7 (RPM binaries for SuSE 9.1 available at ftp.sernet.de/pub/samba/)
- samba 2.2.12 - current stable version from 2.x series (sources from samba.org - manually build)
- samba 2.2.8a - this version comes with SuSE 9.0 (old sources I loaded from a samba.org mirror - manually build)
With all these versions the same problem - the contents of the mounted directory is owned by root. So I guess the problem has something to do with a changed system configuration, changed shared libraries or kernel update.

This problem was described some times before in this list, but I could not find any answer for this issue.

I hope someone who solved it can help me or give me a hint what I could trie next to find a solution.


More information about the samba mailing list