[Samba] Server not responding after Samba upgrade

David Ferreira dferreira at izanet.com
Mon Oct 4 10:38:22 GMT 2004

Dusan Djordjevic wrote:

>On Monday 04 October 2004 09:54, David Ferreira wrote:
>>Dusan Djordjevic wrote:
>>>>I used to run Samba 2.2.9 on Debian Woody. Yesterday I upgraded it
>>>>(with all necessary packages) to 3.0.7. Since then, Samba on that
>>>>server do not respond to netbios queries, only to direct access via
>>>>IP. Also, when I try to resolv its name using nmblookup, I cannot
>>>>find it.
>>>>When I access to server via IP address everything works fine.
>>>Hi again,
>>>Yet I did not solved problem. I noticed one thing. Although nmbd is
>>>running (it exists as process), swat says it is not running. So most
>>>probably problem is with nmbd, but i do not know what to try.
>>Did you tried to startup manually from command prompt? Just try to
>>run as root  nmbd  -D and see what happen.
>Yes, it starts in that case also. Problem is that, although process 
>exists, it is not working properly.
And running  the command "nmblookup machinename" it should give it 
something like this:

#nmblookup machinename
querying machinename on machinename<00>

did you have on your smb.conf any of this parameters?
dns proxy
wins proxy
wins server
wins support

anyway, I think your problem must be related to winbind, not wins, 
because I think you don't have any wins server  in your network. Is that 
right?  Is winbind daemond running? something remarkable on log files? 
increase verbose level of logs if not, and please, give more specs about 
your system and network configuration. clients  work properly? what are 
the OS of clients? some firewall update on smb server? Did you have try 
to downgrade to check if working?

David Ferreira

More information about the samba mailing list