[Samba] Problem with XP after upgrade from 2.2 -> 3.0

Tony Breeds tony at bakeyournoodle.com
Sun Oct 3 09:43:07 GMT 2004

Hello All,
	About 2 weeks ago I upgraded from debian woody to sarge.  This
included an upgrade from Samba2.2 -> Samba3.0.  However since the
upgrade I have problems using my Samba server from my XP (home) Laptop.

The symptoms are basically "explorer" freezeing on most network
browseing type actions.  Or if I open a file (eg a movie).  I'm pretty
confident that I don't have a hardware level nor a basic IP
type problem, as DNS and all other network actions are unimpared.

The message shows up as:

[2004/10/03 19:19:54, 0] lib/util_sock.c:read_socket_data(384)
  read_socket_data: recv failure for 4. Error = Connection reset by peer

I've enabled debug level 10 and loads of tcpdumps but nothing stands out
as being obviously wrong.  Out of some bizzare hunch I added "max
protocol = LANMAN2" and restarted samba.  This has made the problems
dissapper.  However my wife has an older notebook and is still running
Win98se, "dropping" the protocol level to LANMAN2 seems to break her
machine.  I rarely use windows on my laptop but it'd be nice to be wheer
I was before the upgrade.

I've seen other people report what appears to be similar problems (both
here[1] and other lists[2]).  Does anyone have any idea where to look for a
better solution that swapping the protocol level based on the client?

I've tried 3.0.6 and 3.0.7, I've also tried upgrading to SP2 (I have
turned off the firewall).

If this is a known problem I'd really appreciate being pointed at the

Yours Tony

[1] http://lists.samba.org/archive/samba/2004-September/091704.html
[2] http://lists.samba.org/archive/linux/2004-October/012076.html

        linux.conf.au       http://linux.conf.au/
	Apr 18-23 2005      The Australian Linux Technical Conference!

More information about the samba mailing list