[Samba] input/output error

Ken MacFerrin lists at macferrin.com
Sat Nov 27 08:30:36 GMT 2004

Alex Kabanov wrote:
> hi all!
> I can mount smbfs share, but when I try to edit file on
> that mount it gets locked and in the log file I've got this:
> kernel: smb_trans2: invalid data, disp=0, cnt=0, tot=0, ofs=0
> kernel: smb_add_request: request [0b82ce40, mid=26] timed out!
> kernel 2.6.9
> samba 3.0.8, 3.0.9
> OS fedora core 3, (tried on freebsd, samething)
> tried to play with server settings, nothing
> helped (windows boxes work fine with the same server)
> Any suggestions?
> Thanks
> Alex

Try adding "unix extensions = no" to your smb.conf on the server and
restarting samba..  I just recently started having the same issue with
my Gentoo clients but as in your case, the windows clients were fine.
It seems a recent update hosed cifs somehow..  Adding the above line
turns off the cifs extensions and cleared up my problem..

Server & clients both running:
2.6.9-gentoo-r6 + Samba version 3.0.8


More information about the samba mailing list