[Samba] problem setting up dfs

Arthur van Rooij arthur.vanrooij at wldelft.nl
Tue Nov 23 15:15:51 GMT 2004


I'm trying to set up msdfs on FreeBSD 4.10 with samba 3.08.
The clients I use are WinXp (sp1) and the desktop browser on RedHat ES3. 
Problems described beneath are identical for both clients.

I tried to follow the howto as precisely as possible to not into 
problems, however, I did...

In /export/dfsroot I made a link msdfs:strsvr01\part0 . I made sure 
everything is in lower case.

When I browse the shares with a client I can see the dfsroot okay, but 
the link to the secundairy server is mangled to 8 chars. It shows up as 

This is a snip from the user log with log level 10:
[2004/11/23 11:22:57, 5] smbd/trans2.c:get_lanman2_dir_entry(968)
  get_lanman2_dir_entry found ./msdfs:strsvr01\part0 
[2004/11/23 11:22:57, 10] smbd/mangle_hash2.c:name_map(607)
  name_map: msdfs:strsvr01\part0 -> 773A4B48 -> MX2XKC~O (cache=1)
[2004/11/23 11:22:57, 10] smbd/trans2.c:get_lanman2_dir_entry(1052)

Apart from this it all functions okay this way, but I want to get rid of 
the mangling.

 I set mangling method  to "hash" ( it defaults to hash2) and tried 
again. Now I can see the link under the dfsroot, but precisely as it is 
on the ufs filesystem:  msdfs:strsvr01\part0 and I can't open it anymore.

A snip from the user log with log level 10:
is_msdfs_link: ./msdfs:strsvr01\part0 -> msdfs:strsvr01\part0
[2004/11/23 14:05:52, 5] smbd/trans2.c:get_lanman2_dir_entry(935)
  get_lanman2_dir_entry: Masquerading msdfs link ./msdfs:strsvr01\part0 
as a directory
[2004/11/23 14:05:52, 8] smbd/dosmode.c:dos_mode(283)
  dos_mode: ./msdfs:strsvr01\part0
[2004/11/23 14:05:52, 8] smbd/dosmode.c:dos_mode_from_sbuf(151)
  dos_mode_from_sbuf returning d
[2004/11/23 14:05:52, 8] smbd/dosmode.c:dos_mode(315)
  dos_mode returning d
[2004/11/23 14:05:52, 5] smbd/trans2.c:get_lanman2_dir_entry(968)
  get_lanman2_dir_entry found ./msdfs:strsvr01\part0 
[2004/11/23 14:05:52, 5] smbd/mangle_hash.c:name_map(611)
  name_map( msdfs:strsvr01\part0, need83 = False, cache83 = True)
[2004/11/23 14:05:52, 5] smbd/mangle_hash.c:name_map(637)
  name_map() ==> [msdfs:strsvr01\part0]

I tried another dfs link with mangling method defaulted to 2. This link 
was called part1. This one showed up as MX2XKC~P ( where part0 was 
MX2XKC~O) so there must be some translation problem here.

Also I did some fiddling around with the "unix charset" setting. I tried 
ascii as well as utf8, but to no avail.

Any ideas?


Greetz from rainy Holland,

Arthur van Rooij

More information about the samba mailing list