[Samba] Samba Internet Proxy Access Problem

Данаил Брънеков cmbpt at abv.bg
Sat Nov 20 22:12:09 GMT 2004

Hi, guys!

I am using internet via a proxy. When samba is not running, there is no problem, but when I start samba, there is no internet (although there is a ping to the proxy) and whenever I try to open a site, the message "Unauthorized..." appears in the browser. I am currently using Slackware 10.1, kernel 2.4, samba version 3.0.7 (but it was the same on Gentoo. Surprisingly, samba worked fine on Mandrake 9.1, or maybe it worked, because I did not have to make any tuning :-) ). 

I noticed that when only smbd is running there is internet access, but as long I start nmbd, it disappers.

Here is my smb.conf file:


# workgroup = NT-Domain-Name or Workgroup-Name
   workgroup = <my_workgroup>
   netbios name = <my_pc_name>
# server string is the equivalent of the NT Description field
   server string = Samba + Slackware

# Put a capping on the size of the log files (in Kb).
   max log size = 50

   security = share

# Most people will find that this option gives better performance.
# See speed.txt and the manual pages for details
# You may want to add the following on a Linux system:
#         SO_RCVBUF=8192 SO_SNDBUF=8192
   socket options = TCP_NODELAY

# Browser Control Options:
# set local master to no if you don't want Samba to become a master
# browser on your network. Otherwise the normal election rules apply
   local master = no

# DNS Proxy - tells Samba whether or not to try to resolve NetBIOS names
# via DNS nslookups. The built-in default for versions 1.9.17 is yes,
# this has been changed in version 1.9.18 to no.
   dns proxy = no

#message command = ksalup -winpopup "%m" "%t" %s; rm %s
#message command = sh -c 'echo eqweqweq > /aaa'&

There are no entries concerning samba in /var/log/messages.

Here is /var/log/samba/log.smbd:
[2004/11/21 00:06:30, 0] smbd/server.c:main(760)
  smbd version 3.0.7 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2004
[2004/11/21 00:06:30, 0] smbd/server.c:main(794)
  standard input is not a socket, assuming -D option

And here is /var/log/samba/log.nmbd:
[2004/11/21 00:06:42, 0] nmbd/nmbd.c:main(664)
  Netbios nameserver version 3.0.7 started.
  Copyright Andrew Tridgell and the Samba Team 1994-2004
[2004/11/21 00:06:42, 0] nmbd/nmbd.c:main(683)
  standard input is not a socket, assuming -D option
[2004/11/21 00:07:00, 0] nmbd/nmbd.c:terminate(54)
  Got SIGTERM: going down...

Nothing interesting, isn't it?
So, any ideas?

Best regards,

http://www.SPORTNI.bg - Всичко от света на спорта!

More information about the samba mailing list