[Samba] Change Group/Permission problem

jsz at rdslink.ro jsz at rdslink.ro
Sat Nov 20 10:08:00 GMT 2004


I'm using samba as a Domain Controller, and i have the following

It is possible to change an object's (file/dir) GROUP from Windows
Explorer on a Samba server? I tried editing/changing via Security tab the
unix-mapped Special Permission trio ($user, $group, Everybody) but it
fails when I tried to save with the "Unable to save permission changes on
<object>. Permission denied" message. I was logged in as admin user. Unix
<-> NT Group mappings are OK. Everything else works fine, so I can take
ownership, I can change other file/dir permissions like Read/Write/Exec on

Tried on systems:

RedHat 7.3
samba-3.0.9 (rebuilt from samba.org-wendored .src.rpm)
(also tried with 3.0.7)
ext3 fs

Fedora Core 3
2.6.9-xxx (latest update at this time)
samba-3.0.8pre2 (original distro build)
ext3 fs

I also tried changing GROUP using smbcacls, and if I used

   - with -G <groupname> works OK, the object's group is changed
   - with -M GROUP:<groupname> fails as did not returns any error message
     but no change happen

Same effect if I tried changing the OWNER via smbcacls, -C works fine,
-M OWNER:<ownername> fails to produce any changes without an error.

I tried this on all of my systems, the same effect all the time.

If You need further data such as my smb.conf just ask for it, I
didn't want to flood the list with unsolicitated information.

Any clue?


More information about the samba mailing list