[Samba] Error with ACLs and follow symlinks=no

Jeremy Allison jra at samba.org
Wed Nov 17 00:16:59 GMT 2004

On Tue, Nov 16, 2004 at 04:07:15PM -0800, Tom Dickson wrote:
> Hash: SHA1
> We had 3.0.2a which worked fine. If you tried to open a file that the
> ACLs wouldn't let you, you'd get access denied. We had follow
> symlinks=no in smb.conf
> Now with 3.0.8, and no other changes, we get a message about "The file
> has moved or otherwise gone away," instead of access denied.
> And we get this in the log file:
> [2004/11/16 15:57:25, 1] smbd/vfs.c:reduce_name(896)
> ~  reduce_name: couldn't get realpath for B/*
> Changing follow symlinks=yes fixed it. Is this a bug? I'd like to use
> ACLs and follow symlinks=no.

What client are you using to open the file ? I'll check this for
3.0.10 as I'm currently working in this area. It'd be easiest if
you could reproduce using smbclient - can you give me an exact
method to reproduce (paths you're using, acls you have set etc).


More information about the samba mailing list