[Samba] solaris samba ldap

synrat synrat at wirewalk.org
Tue Nov 16 21:03:06 GMT 2004

I'm trying to build 3.0.8 on solaris 9.

I tried linking against both sun and openldap libraries,
both unsucessufully.  I get


checking for LDAP support... auto
checking ldap.h usability... yes
checking ldap.h presence... yes
checking for ldap.h... yes
checking lber.h usability... yes
checking lber.h presence... yes
checking for lber.h... yes
checking for ber_scanf in -llber... yes
checking for ldap_init in -lldap... no
checking for ldap_domain2hostlist... no
checking for ldap_set_rebind_proc... no
checking whether ldap_set_rebind_proc takes 3 arguments... 3
checking for ldap_initialize... no
configure: WARNING: libldap is needed for LDAP support


Using libraries:
     LIBS = -lsendfile -lsec -lgen -lresolv -lsocket -lnsl -ldl
     AUTH_LIBS =

the build completes without linking to libldap or liblder, samba
starts but doesn't recongnize any ldap settings.
configure options below.

CC=cc LDFLAGS="-L/usr/local/openldap/lib" 
./configure --with-ldapsam

also tried settin LD_LIBRARY_PATH to /usr/local/openldap/lib,
but that didn't make a difference.

More information about the samba mailing list