[Samba] More Printing Fun (Point and print not working)

Jason Balicki kodak at frontierhomemortgage.com
Tue Nov 16 17:29:59 GMT 2004

In regards to slow XP to Samba printing with SP2:  I
received an updated driver from the vendor that fixed
the problem* (to a degree.)  So, now I can go back to
using point and print instead of using IPP to print
directly to CUPS.

Oops, no I can't.

When I try to install the point and print drivers
in Windows, the drivers transfer to the server, but
when I click OK to close the properties window I get:

"Printer settings could not be saved.  Access is denied."

There is very little info out there concerning this
error message in regards to Samba.  The only clear
"I fixed this" I could find dealt with the "use
client driver" directive.  I've had this set to
yes and no, but I get the same error message both
ways.  (Yes, I restarted Samba.)

This worked before I switched to 3.0.x.  I was using
2.2.8a at the time things worked.  I switched because
I was having a lot of slow printing issues and I 
stopped messing with it because I ended up bypassing
Samba completely and printed directly to CUPS.

I'm now running Samba 3.0.7 (I will upgrade to 3.0.8
as soon as I can.)

The permissions on the printers/W32X86 directory are
set to 777 in desperation.  I can verify that the
driver files are copied to printers/W32X86/3.

Would anyone like to take a stab at helping with this



By "fixed" I mean the wait went from around 30 seconds
for a properties dialog to show up to around 2-5.  It's
still long on occasion, but it's workable.  IPP is instant.
This affects other print operations as well.

More information about the samba mailing list