[Samba] Samba Won't Work

Jesse Castleberry JesseC at DaVinci-MIMS.com
Tue Nov 16 14:01:49 GMT 2004

I tried to get Samba running on my new Trustix installation all day
yesterday with no luck. I'm a newbie, so there's a lot I don't know yet.

At any rate, I have the Smb, nmbd, and smbd services running. I've got my
smb.conf file set up properly from what I can tell. When I try the following
command on my Linux box:

smbclient // -U jesse

I get the error, "error connecting to (Invalid Argument)". I
have tried it without the "-U", and that didn't make any difference. Same
error. When I try to connect from my Windows PC, I get the following errors
in the file log.

[2004/11/16 02:05:47, 0] lib/util_sock.c:open_socket_in(708)
[2004/11/16 02:05:47, 0] smbd/oplock.c:init_oplocks(1308)
open_oplock_ipc: Failed to get local UDP socket for address 100007f. Error
was Cannot assign requested address

Also, when I do a smbpasswd -a jesse, I get the error, "Segmentation fault",
and it doesn't add the user.  This may be the cause of all my problem.

Any ideas what this means, or how I fix it? Remember, I'm a newbie, so I'll
need more details than usual.

Here's my smb.conf:
   workgroup = AWAY_TEAM
   server string = Trustix Secure Linux Samba Server
   security = share
   hosts allow = 192.168.1. 127.
   log file = /var/log/samba/log.%I

#============================ Share Definitions
   comment = Home Directories
   browseable = no
   writable = yes
   writable = yes
   create mode = 0600
   directory mode = 0700
   valid users = %S

   comment = Backup
   path = /backup
   writeable = yes


More information about the samba mailing list