[Samba] Problem with password program setting. Maybe my upgrade did not go good?

Richmond Dyes rdyes at monroehosp.org
Mon Nov 15 13:58:33 GMT 2004

I was running a server with Redhat 9.0 on it.   I had upgraded samba by 
compiling 3.03 on it several months ago.  When I add password 
syncronization I started getting the error:

ERROR: the 'passwd program' (/usr/bin/passwd %u) requires a '%u' parameter

Of course my parameter was right but there was a bug in it.  At that 
point, I decided to use the rpm for 3.08 for redhat 9.0.  The error 
still occurred.  At that point, I had Fedora core and upgraded my system 
without a hitch, or so it seemed.  This took my samba and samba common 
backdown to release 3.03.  I downloaded samba, samba common and samba 
client 3.08 rpms and ran an upgrade. Again it seemed as if worked fine.  
Maybe the upgrades haven't because I am getting the same error.  Is 
there a way I can make sure I have all the right files for samba and 
there isn't a mixture of versions on my server.  Is there a way or 
removing all the samba file and then reinstalling the rpm's?  any help 
or suggestions would be appreciated.

More information about the samba mailing list