[Samba] Windows 2000/2003 shares -> danish character problem

bernt.johnsen at ski.vgs.no bernt.johnsen at ski.vgs.no
Sun Nov 14 15:16:17 GMT 2004


I know this problem is marked as solved, but here is another solution, a
solution which makes it possible still to use smbfs.

I have been working on a project connecting Skolelinux ltsp-server to a
windows 2000 server in norwegian secondary school and came across the same
problem ( that is one of the teachers and his students in my school did

Searching the net I found the solution in

SOLVED - Re: [Samba] Windows 2000/2003 shares -> danish character problem

but Skolelinux which  is based on Debian Woody has a kernel that doesn't
support cifs(to my limited knowledge).

So I tried to follow up the chcp 850-suggestion in the last paragraph from


You may need a win2kx server install cd.

On a 2003 server:

As a administrator open Control Panel -> Regional And Language Settings ->
Advanced tab:

Select a Scandinavian Language in Language for nonunicode programs

On a 2000 server:

As a administrator open Control Panel -> Regional Settings
- > On the General tab click Set Default button:

Select a Scandinavian Language as System Locale

Both 2003 and 2000:

Then a couple of OKs (The install cd may come in handy at this point)

The system needs a reboot and then the code page is 850!

A documentation in norwegian of the whole project will soon be available.

ons, 2004-07-21 kl. 16:06 skrev Martin Moeller:
> Hello all.
> I have been given an assignment to mount a share automatically for each
> user using a given Linux machine (Mandrake 10 in this case). This is
> working fine, thanks to pam_mount, BUT:
> The mounted share contains national characters like this: æ ø å.
> The problem I'm having is that when I mount these on Linux the 'ø' looks
> like 'o' but cannot be accessed like that. It says the file or directory
> doesn't exist (and it has a point). I have seen this on both Windows
> 2000 and Windows 2003 Server. Interestingly enough there are no problems
> with Windows XP, as long as I use codepage=cp850 to mount with.
> I have tried these codepages: cp437, cp850, cp865, cp1250, cp1251, utf8
> I even tried 'latin1' just to see what would happen.
> I guess there is something that should be changed on the Windows machine
> for this to work? If so does anyone know what that would be?
> Part of the problem is that it is a literal 'o' that is shown in the
> Linux filesystem but when this filename is requested of the Windows
> server it of course denies any knowledge of such a thing.
> When I write a file that has 'æøå' *inside* there are no problems
> displaying that. I have tried googling for clues for quite a while now
> and haven't found that much other than 'chcp 850' on the Windows
> machine. This doesn't seem to alleviate the problem when the Windows box
> is the server... Is it a matter of forcing cp850 at a much earlier state
> (running just chcp gives '437')?
> Any takers? :)

Here is one at last ;-)

Best regards

Bernt Johnsen
system administrator
Ski vg skole

More information about the samba mailing list