[Samba] Samba 3.x performance bug?

Magnus Abrante Magnus.Abrante at Sun.COM
Thu Nov 4 14:08:44 GMT 2004

Hello All,

IHAC who is experiencing a strange samba problem, the problems started when
they wanted to migrate a existing Samba installation onto a Sun Cluster node.

They are running Sun Cluster 3.x on a 6800 with 12 CPUs, the operating
environment is Solaris 8.

Its a quite annoying problem, since the Samba instances runs nicely on other
Solaris 8 boxes, but on this cluster node it runs very much slower (it takes
minutes to download a bunch of files from the cluster, but seconds from the old
machine). Also all the other applications in the cluster works fine as well.

To confuse us a bit more, i asked them to try to run Samba 2.2.5 on the
cluster, and that one worked just fine.

We tried the old 3.0.4 release, and the 3.0.7 release, we also tried to
compile different 3.0.7 releases as follows:
* without krb/ldap support.
* without iconv.
* with different optimization flags.
* with profiling.

We used about the same flag as we use for Samba 3.x in Solaris 10.

We also tried compiling it with both gcc and S1S8CC.

I've collected the following data:
* profiling data.
* smb.conf (attached).
* netstats.
* explorers.
* snoop.

Which i can send upon request.

So folks, any ideas?

Best regards,

	//Magnus Abrante

Magnus Abrante                              Sun Microsystems
Product Support Engineer                 Enterprise Services

More information about the samba mailing list