[Samba] Samba3 + LDAP - troubles joining domain (have to do it twice)

Tomasz Chmielewski mangoo at interia.pl
Wed Nov 3 12:55:15 GMT 2004


I have the following test setup:

1) Samba3 + slave OpenLDAP - the same PC, win2k in same LAN
2) OpenLDAP master

OpenLDAP slave and master are divided by a rather slow internet VPN link.

Whenever I want to add a PC to a domain, I have to do it twice - with 
first time I get an error on a client side, second join is successful.

I guess it's because master and slave are divided by slow link, and it 
takes some time to replicate from a master to slave, too, and it all 
confuses Samba as it can't find a username (machine name) it just added.

I tried setting "ldap replication sleep", started with 5000, and tried 
setting it as high as 100000, but it didn't help.

The only consequence of setting "ldap replication sleep = 100000" is 
that I have to wait a couple of minutes before it joins the domain when 
I try to do it for the second time (and succeeds).

With "ldap replication sleep = 5000", it joins the domain in about 15 
secs (when I join the domain for the second time).

The first time I try to join a domain I get an error after about 10-12 
seconds, no matter value "ldap replication sleep" has.

I use smbldap-tools 0.85 for adding users/machines.

Any clue?


More information about the samba mailing list