[Samba] Wierd 8.3 Name Mangling

Brian White bcwhite at precidia.com
Tue Nov 2 22:10:12 GMT 2004

> > I've installed Samba 3.0.7 (stock Debian package), but I'm having some
> > wierd problems with name mangling.  The relevant lines in smb.conf are:
> >
> >    preserve case = yes
> >    short preserve case = yes
> >    mangled names = yes
> >    mangle prefix = 5
> >    mangling method = hash2
> >
> > In a share, I did "touch test-file.GHO" to create a long filename.  When
> > I do a "dir" under DOS, however, it shows:
> >
> >    TVTSSK~S GHO             0  11-02-04  3:07p test-file.GHO
> >
> > I can't see how samba came up with this mangled name.  I tried changing
> > the mangle prefix and/or mangle method but it made no difference.  I made
> > sure I killed the "smbd" process after any changes I made and can see it
> > being restarted and a new TCP connection established to it.
> The mangle prefix is only used in the hash mangling method. The name
> shown (TVTSSK~S GHO) is a has2 mangled name, as to be expected.

Okay, but, as I said, I tried changing the mangle method (to just "hash")
and still got the same results.

Perhaps my Windoze box has cached the result somehow or the correct
process did not restart...  Yup, sure enough...  Reboot Windoze and the
now it shows "TEST-~AM.GHO".


                                 ( bcwhite at precidia.com )

         Don't go around saying the world owes you a living.  The world
              owes you nothing.  It was here first.  -- Mark Twain
  ( Couldn't verify my signature?  Use http://www.precidia.com/precidia.crt )

More information about the samba mailing list