[Samba] Locked files stay locked - copy operation from XP to Samba fails

Bart van Dijck samba at vandijck.demon.nl
Thu May 27 17:41:43 GMT 2004

Jeremy Allison wrote:
> On Thu, May 27, 2004 at 01:43:14PM +0100, Hamish wrote:
>>I am having a very similar problem copying files from the old sbs server 
>>- I thought it might be the onboard nic (1gig on asus board) so I have 
>>installed an intel pro1000 (e1000 module) - this seemed to work but i 
>>have just had another crash (I am a relative newbie to linux so did not 
>>know how to recover from it - top did not show any zombie or cpu hogging 
>>processes - even shutdown-r now would not do it so i did the nasty on 
>>the reset button..)
>>If i copied the directories one by one, it worked fine, but when copying 
>>the whole lot (+- 40G) it dies, seemingly on different files each time.
> If linux crashes hard you have either a kernel bug, driver problem or
> hardware problem. It's not Samba related I'm afraid.
This is not the case in my situation (see OP).

I have four files out of 5000+ that keep getting locked 
(marked ALL_DENY). These are the same files everytime I 
tried to copy them. When I remove these four files I can 
copy all I want. I've checked everything about those files: 
permissions, damage, but I can't find anything wrong with 
them. There is no hard crash and like I said: other files in 
other trees don't give me this problem.

Is there a way to examine in more detail what happens when 
one of those files is marked locked? I'm using a Slackware 
9.1 install with the stock 2.2.8a tgz package.


More information about the samba mailing list