[Samba] Interdomain trusts

Doug Curtis doug.curtis at world-mail.org
Wed May 26 11:52:30 GMT 2004

I am running samba 3.0.4 using ldap and I am having a wierd problem.  I am
trying to setup a one way trust with an NT4 PDC.

The NT4 PDC is the trusted domain and the samba pdc is the trusting.  I setup
the password on the nt4 machine in the trusting field.  When I go to the samba
pdc and type in "net rpc trustdom establish NT4PDC"  it prompts for the
password.  After I type it in it replys:

Could not connect to server NT4PDC
Trust to domain NT4 established

If I type the wrong password, the debugging shows that it was a bad password. 
So it would appear that it is at least communicating with the NT4 pdc.

When I go to login to a machine the is on the samba domain using an NT4 username
and password, it logs me in but it doesn't do any of the normal login
operations.  One example is that the home drive doesn't get mapped even though
it is setup in the user manager.  Also, the NT4 username has to be the same as
one on the samba pdc or else it won't let me login.

For giggles, I tried it the other way (Samba trusted and NT4 trusting).  It
works perfect.  A samba domain user can login to an NT4 domain machine and it
performs the domain login functions.  I even tried a username that did not
exist on the NT4 domain and it worked.

I have been trying to figure this out but nothing gets written to any of the log
files when I try to establish the trust.



More information about the samba mailing list