[Samba] smbd disconnects when trying to write not-very-large files

Jordan Coleman jordan at ColemanFamilyCamps.com
Sat May 22 20:09:20 GMT 2004

Running Samba 3.0.4 on FreeBSD 5.2.1-p3, built from the BSD ports 
collection.  I've got Samba up and running (as I have numerous times 
before with great success) and clients can connect, list files, read, 
rename, delete, etc.  When trying to write a file, though, the server 
disconnects (and, apparently, the forked process that was started for 
the connection quits with no error).  The result is that the file is 
created on the server, but doesn't get filled and the client reports an 
error.  This happens both when saving a file that's been opened on the 
server and when trying to copy a new file to the server.

To be more specific, I can create and write files up to about 1.6K in 
size without any problem at all.  Above about 2K, I always get the 
error.  And in between, sometimes things work and sometimes things don't.

If I copy a folder to the server, things proceed until it gets to the 
first file in the 1.7K+ range and then I get the error.  The directory 
gets created, all files up to that point get copied, and the file it 
stops on gets created but is empty.

On WinXP, the error message that Explorer gives is "The specified name 
is no longer available" (obviously, other apps give other errors).  
Using smbclient from another host, I get "Error writing file: Call 
returned zero bytes (EOF)" or, in some cases, smblient just exits with 
no message.  Interestingly, when trying to connect with smbclient from 
the local machine (the host Samba is running on), everything works just 

I considered that the problem might be a mistake in smb.conf, but I 
tried using the smb.conf from another system where Samba's working fine 
and still get the same problem.  I'm actually having this same exact 
problem on two hosts with identical hardware.  The clients I'm using 
have no problem working with other servers (Samba and XP) on the same 

I've tried to debug this with a packet sniffer and by turning up the 
debug level in the server, but in both cases, the output hasn't given me 
anything that jumps out as being the problem.  OTOH, most of it is 
mostly meaningless to me anyway.

Any ideas?  I can provide packet dumps, logs, etc. if necessary.


More information about the samba mailing list