[Samba] SAMBA 3.0.4 + LDAP + usrmgr

Umberto Zanatta uzanatta at provincia.treviso.it
Thu May 20 07:34:23 GMT 2004


all that's working fine if I'm using by command line; but If I try to
run them by usermgr.exe
only the script «add user script» doesn't work!

The system does:

bdb_dn2id_add: put failed: DB_KEYEXIST: Key/data pair already exists
could not add user/computer prova154 to passdb.  Check permissions?

I've tried add «-P», «-a» before «%u» in the «smbldap-useradd» but it
does nothing,
same result, same error.

Of course, the script for add machine account's working!

It sounds like a bug in samba 3.0.4...

Thanx a lot.


Il gio, 2004-05-20 alle 09:17, Jérôme Tournier ha scritto:

> Le Thu, May 20, 2004 at 08:55:59AM +0200, RRuegner a ecrit:
> > >add machine script = /var/lib/samba/scripts/smbldap-useradd -w %u
> > you have to copy the script in /usr/local/sbin/ cause this is hardcoded
> > in them use this
> >    add machine script = /usr/local/sbin/smbldap-useradd.pl -w "%u"
> Things that are hardcoded in the script are
> . in smbldap-passwd: the path to slappasswd
> . in smbldap-useradd, smbldap_tools.pm: the script to nscd init script
> . in smbldap_tools.pm: the path to configuration files (in
>   /etc/smbldap-tools/)
> The one to take care is the last one, because if configuration's files are
> not in /etc/smbldap-tools/, all scripts will failed.
> -- 
> Jérôme

Umberto Zanatta

tel: +39 (335) 54 71 385
email: umberto.z at tin.it
web: http://linuxdidattica.org

More information about the samba mailing list