[Samba] Version 3: %U returns null value in security = share

Gavin-Francis Fernandes gavsta at gavsta.com
Mon May 10 13:09:20 GMT 2004

Dear Samba Gurus

We have been using samba to work a print solution for our University for
quite sometime, where the user doesn't need an account on the domain, nor
does the PC need to be part of our Domain or Workgroup.  Users can print to
the machine via \\server\printershare and this has worked perfectly in the
past, because %U is returned as the username their workstation recognises
them as, or basically %username% from their workstation's environment
variables.  I use a perl script to do some stuff after we receive the job,
based on the username they requested.

When we upgraded to v3 (pretty much any build that we've tried) all of a
sudden, the %U variable/macro is null.  This is not so if I join the samba
machine to the Domain/AD and use security = domain or server.  Then %U is
returned correctly, but this means that all the users need to be in a
domain, where our students bring in their own machines and we have no
control over their domain memberships etc.

If I downgrade back to 2.2 I have no troubles.

Any ideas?

Gavin Fernandes
MSN: gavsta at gavsta.com

More information about the samba mailing list