[Samba] Problem with migrating from one samba fileserver to another

Daniel Meyer eagle at cyberdelia.de
Tue May 4 11:10:50 GMT 2004

Hi everyone,

i've got a little problem with copying data from one fileserver to another.

Server1 is a samba 2.2.7a server, joined to a Windows ADS via rpc.
Server2 is a samba 3.0.2a server, joined to the same Windows ADS via ads.

How do i copy data from one server to another without loosing ownership 
and security settings of the files?

things i tried so far:

- Mount one share from each server, and copy via scopy from the windows 
resource kit. Doesnt work because scopy doesnt recognize the samba share 
as ntfs, and fails to copy ownership/security information

- trying the same procedure with robocopy, same result

- mounting one share from Server1 with smbmount. Doesnt seem to 
regognize the security settings and messes up the uid/gid mapping

- copying all .tbd files from Server1 to server2 and retry smbmount: 
still messed up uid/gid mapping...

Any ideas?
"The future is not set. There’s no fate but that
which we make for ourselves."                       -Sarah Connor, T2-

"Information wants to be free"                       -unknown source-

More information about the samba mailing list