[Samba] Samba 3 ldap password sync

Kevin Metz kbmetz at yahoo.com
Mon May 3 19:18:39 GMT 2004

Well, I seem to have gotten past the most difficult parts as far as Samba and LDAP
are concerned. I'm able to have a user log in to the domain, and get authenticated
via LDAP. The user can also change the LDAP password from the Windows screen
(control-alt-delete->change password). So most stuff as far as the windows domain
login appears.
My problem is this. Linux and other users need to be able to change their ldap
password. If they log into the box, or change it via a web interface it changes
their ldap password, but samba doesn't seem to recognize it. For example as root I
changed a users password via the command line and it said it was changing the LDAP
password. I confirmed the password was changed by accessing a web page that
authenticates using ldap and the new password worked. I then tried to access via
samba and the new password did no work.

Am I doing something wrong or missing something obvious? Does samba cache passwords
somewhere? I've got ldap sync set to on but that doesn't appear to be working. 

Any help would be greatly appreciated

kbmetz at yahoo.com

Do you Yahoo!?
Win a $20,000 Career Makeover at Yahoo! HotJobs  

More information about the samba mailing list