[Samba] Samba 3 OK at smbclient, Windows fails

vvp vp1242 at mail.ru
Sun Mar 28 11:55:56 GMT 2004

Hi everybody,
    I failed to make Samba 3.0.0 /3.0.2a working from Windows side on the 
slightly different Slackware’s.
    Last try was the “current” Slackware version(kernel 2.4.25) of some
March 20’s with Samba 3.0.2a in it. Server: Asus P4P800-PIV–RAM 1.5(1)Gb-
3Com 3C940 integrated. Client(s): W2k SP3, Realtek 8139 NIC.
    Installed OK (binaries from a distribution…), user added OK after
useradd to Linux. Share path is owned by that user and 'chmod a+rwx'ed.
Swat works OK except that it always insists that smbd is not running(?). 
Smbclient was tried at mget/mput Windows distribution (in thousands of
files), ran at some 6 Mbytes/sec.
    My smb.conf:
	workgroup = WORLD
	server string = Samba Server
	log level = 3
	log file = /var/log/samba.%m
	max log size = 50
	socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
	os level = 64
	preferred master = Yes
	hosts allow = 192.168.0., 127.
	comment = NO
	path = /share/AAA
	read only = No
	guest ok = Yes

    From Windows side I can open shares, list folders, create the
new ones... but get stuck immediately when trying to make ANYTHING with
the files slightly larger than few bytes. In fact, it was the same when
trying to browse large directories (some hundred files). Sure Mr. Gates
never gives up and keeps trying few times adding new smbd processes and
file locks...
    Attempts to play with (switching off) locks when I was yet at 3.0.0
didn't help. Nearly the same was with W98, except that large directory
browsing was OK.
    I tried to find something in my /var/log/*, but it seems mostly the
errors at re-connections, re-locks and inabilities to break old locks.
    Could anyone help?

More information about the samba mailing list