[Samba] winbindd/Samba3 on RHEL 3.0 [RESOLVED]

Chris Purcell redhat at cjp.us
Fri Mar 26 15:21:18 GMT 2004

> Samba 3.0.2
> Red Hat Enterprise Linux ES 3.0
> I'm trying to set up winbind and all of the wbinfo commands are failing.
>  I was able to join the domain with this command...
> root at tux samba# net join -S typhoon -U Administrator
> Administrator password:
> [2004/03/25 16:53:46, 0] libads/kerberos.c:ads_kinit_password(133)
>   kerberos_kinit_password Administrator at foo.org failed: Cannot find KDC
> for requested realm
> Joined domain FOO.
> ...but all of the wbinfo commands fail..
> root at tux samba# wbinfo -u
> Error looking up domain users
> root at tux samba# wbinfo -t
> checking the trust secret via RPC calls failed
> error code was NT_STATUS_DOMAIN_CONTROLLER_NOT_FOUND (0xc0000233)
> Could not check secret
> root at tux samba# wbinfo -a jdoe%password
> plaintext password authentication failed
> error code was NT_STATUS_NO_SUCH_USER (0xc0000064)
> error messsage was: No such user
> Could not authenticate user jdoe%password with plaintext password
> challenge/response password authentication failed
> error code was NT_STATUS_NO_LOGON_SERVERS (0xc000005e)
> error messsage was: No logon servers
> Could not authenticate user jdoe with challenge/response
> getent passwd and getent group DO work though.
> I've done this before in the past on Red Hat 9 machines and it worked
> everytime.   Maybe this problem has something to do with the fact that
> this server is on a different subnet from the domain controllers?
> Thanks,
> Chris

I fixed this problem by running this command...

net rpc join -U Administrator

Before that, I was using "net join -S PDC -U Administrator", which seemed
to work, but didn't.

Can someone please tell me why this worked to begin with?  I'm not sure
what the difference is.


More information about the samba mailing list