[Samba] MS Word doesnt set attribute bits on share

ben ben at frazer-nash.com
Fri Mar 19 10:50:27 GMT 2004

Hi All,

I first psoted this in on the technical list but not sure if it shouldnt 
be here instead.

I have searched the mailing lists for this problem and cant find any 
answers so I am posting this here in the hopes of some help.

I have a samba test server (v 3.0.1) running on Redhat 9 kernel  2.6.1 
with acl support enabled.

Also another live samba server (v 3.0.1) running on Redhat 9 kernel 
2.4.20-8 with no acl support.(to be updated when test server is ok).

The problems I am having exist on both servers and involves the archive 
bit not getting set properly. This causes problems with our backup 
software. If I cant fix this problem I will have to consider moving the 
server back to MS which I dont really want to do.

smb.conf contains the following
         map archive =  Yes
         map system = Yes
         map hidden = Yes
         dos filemode = Yes
     create mask = 0777

         comment = Home Directories
         valid users = %D_%U
         read only = No
         oplocks = No
         level2 oplocks = No
         browseable = No

Have tried with oplocks enabled and disabled as well.

I have tried both Win2k and WinXP clients.

On the live server NON Word files seem to get the archive bit (mapped to 
x user unix bit) set correctly as long as it is the owner modifying the 
file. If any other user changes the file the bit doesnt change. I know 
this is down to linux only allowing the owner to change permission bits.

With Word files, even if the owner modifies it, the archive bit does not 
get set. I am using MS Word 2000. I can see Word create a temp file of 
the same name with the first 2 letters changed to ~$ . I assume this is 
for file locking, and gets deleted after the document is closed. Once 
closed the attributes of the original file remain unchanged. The date 
modifed is changed.

The test server is slightly differnt as I have modified dosmode.c to 
save the dos attributes in a unix extended attribute, based on a section 
of code Jeremy posted in another thread for samba v2.2.x.

This seems to work lovely and allows non-owners of a file to set the 
archive bit correctly. However I still have exactly the same problem 
with Word. Heaven knows what MS are doing. Curiously Excel 2000 has no 
such problems on either system.

It is just not the archive bit that is not being set. I have noticed on 
an NT server, the temporary file created by MS Word is also hidden, but 
on the samba server this is also not getting set either.

I am thinking MS Word must be trying to set the attribute bits in a non 
standard way.
I have no problems changing the attirbutes from the properties in 
windows explorer.

***** addendum ******
Have also now tried using Word from Office 97 running on Windows 98 and 
it appears to set the archive bits correctly. Not sure if this is 
because it is a different version of Word or a different version of Windows.

many thanks for any thoughts.

More information about the samba mailing list