[Samba] 2gig limit

frank jenkins fjenkins873 at hotmail.com
Tue Mar 16 16:57:06 GMT 2004

I'm running into a 2gig file limit when copying files from a linux machine 
running smbmount 3.0.2a-Debian and kernel 2.4.23 connecting to another 
debian machine running smbd 3.0.2a-Debian with the stock 2.4.18-bf2.4 kernel 
that comes with debian stable (though the machine has been upgraded to sid).

If I run this on the client side

dd if=/dev/zero of=test.junk bs=1k

it eventually fails at the 2gig mark. If I run it on the server side, while 
running 'ls -l' on the client side, the file size is reported correctly up 
to 2 gigs. Ex:

-rwxr-xr-x    1 jenkins jenkins 1988903936 Mar 15 19:57 test.junk

As the 'dd' on the server side passes 2gigs, the filesize reported by 'ls 
-l' on the client side jumps up a tad:

-rwxr-xr-x    1 jenkins jenkins 18446744071976267776 Mar 15 20:00 test.junk

Any idea what is causing this? I've tried searching around on google, and it 
seems this was a problem back in 2000-2002, but was fixed in one of the 2.* 
versions, so I'm not sure why I'm having this problem.

Thanks, Frank

Store more e-mails with MSN Hotmail Extra Storage – 4 plans to choose from! 

More information about the samba mailing list