[Samba] lock/shared file problem

Lorant Toth LorantToth at gmx.net
Sat Mar 13 19:30:44 GMT 2004


I am new to this list, so ... :)

I seem to have a "share" problem with an app, while it is running I 
cannot overwrite files that it seems to have "open" - when using an NT 
server this should work.

long :)
I have following problem with my Samba server:

It is serving for a "distributed" (serves three workstations) 
proprietary app. That app mostly reads and modifies files thru Btrieve ( 
I don't like it but I have no choice ) using local btr dll's, I am not 
running a btrieve server.
This app has an "update" (sub)program, that prog is called from within 
the app and calls windows' "file copy operations" (as far as I can tell 
the standard windows file copy dialogs appear) to copy/overwrite the 
install files on the server - then the copied installer is called on 
every workstation. Everytime I run the update app I get "Could not copy 
file $bla$. Access denied. In use by another application?" (or alike - 
the msg is in a different lang). If I do the same manually while still 
running the app using xcopy it works, but if I try to overwrite any file 
from within windows (explorer e.g.) while the app is running I get the 
same error.
As far as I can tell, this seems to be a share or lock problem - have 
been reading all of the man I could find on this issue and played with 
all oplock and directory/create mask settings w/o success. My other 
thought was that it is due to wrong permissions but afaik they seem 
right - now I actually set file and dir create mask to 0777 and force 
masks to 0775 and no luck.
Does anybody have an idea?

I'd very much appreciate help b/c I could find anything about this 
online or in the docs.

- Lorant

More information about the samba mailing list