[Samba] winbindd problem - STATUS_BUFFER_OVERFLOW (0x80000005)

bryce lord_ph at comcast.net
Thu Mar 11 22:27:35 GMT 2004

I had the same problem. Error and all. What turned out to be my problem 
was that i was using gentoo and building things for a pentium4, which 
gcc3.2 makes bad binaries for.

So changed everything to build for a pentium3 and the problem was 
solved. I don't know if this applies to you, but something to be aware 
of none the less.


Daniel Meyer wrote:

>> I did some more tests and this is what i learned:
>> - I did a similar setup in our lab, also with a w2k server (ads in
>>   mixed mode), a firewall (same type as in the "real world" scenario),
>>   and identical linux/samba setup
>> - That lab-setup works just fine, so it is not a compilation issue or
>>   errors in the samba.conf
>> - exactly the same smb.conf/krb5.conf on the "real world" system gives
>>   the same error as before. The only thing i changed is the name of ads,
>>   realm and password-server.
>> So it looks like either a problem with the firewall between the samba 
>> server and the windows dc, or some problem with the dc itself. I 
>> rather doubt that the problem is on the firewall side, both lab and 
>> real world firewall are the same model, same software, and both have 
>> all ip traffic between samba and dc permitted.
>> Does anyone have an idea what and where i can check on the windows 
>> side? Its a windows 2000 server, servicepack 4, english 
>> installation... nothing fancy...
> Some more research. Removing the firewall doesnt change anything, so i 
> dont think the firewall is causing my problem. I re-checked the 
> windows server, and saw its a SP3 box, my lab-Server had sp4. I'll 
> check again with an sp3 lab-server.
> But so far, i'm still stuck with the following error:
> root# net rpc join -U administrator -w DOMAIN -S WINDOWS-DC
> Password:
> [2004/03/11 16:51:54, 0] utils/net_rpc_join.c:net_rpc_join_newstyle(326)
>   Error domain join verification (reused connection): 
> Unable to join domain DOMAIN.
> Joining with "net ads join..." works, but then wbinfo fails again.
> Danny

More information about the samba mailing list