[Samba] Re: CIFS, fstab, credentials - one more solved, but new issue

Dexter Filmore Dexter.Filmore at gmx.de
Wed Mar 10 00:20:58 GMT 2004

On 08 Mar 2004 14:47:00 -0600
Steve French <smfltc at us.ibm.com> wrote:

> I will take a look at the credential files parsing and make sure it
> works with the version of mount.cifs built on the web site and the
> version built from source in samba cvs.

> I don't recognize the other problem with early mount soon after boot
> failing with rc=22 (presumably EINVAL invalid parameter).

Um, I figured that one - Slackware simply isn't ready for CIFS out of the box,
one needs to exclude cifs entries from rc.S (Slackware's main start script)
and add umount/mount lines to rc.0 and rc.inet2, all in /etc/rc.d/ in case
somebody wanna try)

So - now I thougth everything but the credentials thing was fine, System
boots, mount, unmounts etc etc until I discovered something new today:

When transfering a large file from client to server, the process stalls and
becomes unresponsive all of a sudden.
The system will carry out orders (like keyboard entries, mouseclicks if in X)
no more often than once per minute and I have to kill -9 it. (cpu load does
not rise).
Tried cp, mv, dd, copy with midnight commander, all the same, targets were XFS
and ext3, no difference.
When remounting with smbfs all is fine. 
I have a suspicion who might be the culprit here: the disk. on my home server
it's a 5400rpm drive which hosts OS and swap as well and hence isn't that
fast, is it possible that CIFS borks when the client puts faster than the
server can write and hits some buffer limit or such?
i will try to copy to /dev/null for laughs and tell how it went. (don't wanna
risk sys instabilities now)

Apart from that, keep up the work, imo cifs supercedes smbfs by far.


More information about the samba mailing list