[Samba] Can't create files using Mac OSX Client against Samba server on Debian Linux

Thomas Chadwick j_tetazoo at hotmail.com
Sat Jun 26 23:24:37 GMT 2004

So I have my Debian Linux (latest stable release) box setup as a Samba 
server for my home LAN.  What I'm trying to do is share a single directory 
(not a home directory) to any/all computers on the LAN.  I have several 
Windwos client (a mix of Win9x, Win2000, and WinXP) as well as an iBook G3 
running OSX 10.2.6.

This share works great from all of the Windows clients.

>From the iBook, I can read files without any issues.  Where I run into 
problems is when I try to drag-and-drop a file from the iBook to the Samba 
share via the Finder GUI, I get the error message:

The operation cannot be completed because you do not have sufficient 
privileges for "filename".

I also am unable to create files on the share using File->Save from any 
GUI-based apps (e.g. TextEdit).

Strangely enough, if I open a Terminal window on the OSX client, and cd to 
the share (in /Volumes), I can copy/create/delete files to my heart's 

I'm sure it must have something to do with those pesky resource files.  In 
my smb.conf file I have "hide dot files = no", and "hide files" and "veto 
files" are undefined.  For kicks, I also tried enabling "map system", "map 
hidden", and "map archive" to no avail.

Any more suggestions?


Is your PC infected? Get a FREE online computer virus scan from McAfee® 
Security. http://clinic.mcafee.com/clinic/ibuy/campaign.asp?cid=3963

More information about the samba mailing list