[Samba] Samba+LDAP Joining domain...weird problem!!!

Mohammad Reza reza at mra.co.id
Fri Jun 25 02:03:59 GMT 2004

I have some problem to with samba-3.0.3-5 (fedora package), but i'm sure that Administrator password is correct, and have uidNumber=0.
And smbd.log said that i can connect to LDAP server.
How to debug or solve this matter ?
Please help me...
[root at lab root]# smbldap-usershow administrator
dn: uid=Administrator,ou=Users,dc=mragroup,dc=net
cn: Administrator
sn: Administrator
objectClass: inetOrgPerson,sambaSAMAccount,posixAccount,shadowAccount
gidNumber: 512
uid: Administrator
uidNumber: 0
homeDirectory: /home/Administrator
sambaLogonTime: 0
sambaLogoffTime: 2147483647
sambaKickoffTime: 2147483647
sambaPwdCanChange: 0
sambaHomePath: \\PDC-SMB3\home\Administrator
sambaHomeDrive: H:
sambaProfilePath: \\PDC-SMB3\profiles\Administrator\
sambaPrimaryGroupSID: S-1-5-21-972941785-1405270838-3938555588-512
sambaSID: S-1-5-21-972941785-1405270838-3938555588-2996
loginShell: /bin/false
gecos: Netbios Domain Administrator
sambaLMPassword: 42CD4C7F818D4973AAD3B435B51404EE
sambaAcctFlags: [U]
sambaNTPassword: 2FE8B5F75CF04A070222E0B49058EAA8
sambaPwdLastSet: 1088091927
sambaPwdMustChange: 1091979927
userPassword: {SSHA}vMIArCQ3m2yn4sjieOltxPZzkS+O4uWs

	-----Original Message----- 
	From: Lance Levsen [mailto:l.levsen at pwgroup.ca] 
	Sent: Fri 6/25/2004 12:12 AM 
	To: abebe lsslp 
	Cc: Samba Samba 
	Subject: Re: [Samba] Samba+LDAP Joining domain...weird problem!!!

	On Thu, Jun 24, 2004 at 08:25:27AM -0700, abebe lsslp wrote:
	> This seems to be working fine. However, as I try to
	> join the domain from 'winxp' (logged in as
	> 'Administrator' and using 'root'),I still get "Access
	> is denied" message on the xp workstation. The weird
	> thing is, I don't see anymore logs in
	> /var/log/messages, smbd.log, or winxp.log. I have
	> tried restarting the XP computer as well.
	Try adding the samba machine first from the commandline to see if your
	user has the correct perms.
	$> net rpc join -w domain -UAdministrator%password
	The user who joins machines to the domain has to have a uid of 0 on
	the samba box. Here, I had to change the Administrator uid in LDAP to
	> Ambex
	Lance Levsen, Linux Systems
	Catprint Computing
	To unsubscribe from this list go to the following URL and read the
	instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list