[Samba] Re: Help with: "Cannot copy Filename: The specified network name is no longer available" error

Stephen Jones hivemynd at hivemynd.net
Tue Jun 22 04:35:13 GMT 2004

Hello All,

I am encountering the exact same error message when accessing SMB shares
through a pptp tunnel (using the linux pptp client on a SmoothWall gateway).
The linux pptp folks pointed me towards the samba lists as this appears to
be the source for SMB/NMB gurus where linux is involved.

I have a pptp tunnel to a remote SMB share that is accessible to clients
behind the gateway.  I don't experience any problems (so far) when accessing
the file shares or transferring files across the ppp link from a single
client.   As soon as a second client initates any kind of SMB traffic across
the ppp tunnel, the first clients session halts with the "Cannot copy
{filename}: the specified network resource is no longer available."  message
(exactly like the author of this thread describes.)  The traffic started by
the second client continues, until another client intiates SMB traffic, and
so on.  The ppp tunnel does not freeze or hang, or die, only the SMB session
is terminated.  The SMB shares are immediately accessible from the first
client, but doing so kills the second session, etc.

A tcpdump capture on the gateway reveals a series of 4-6 packets described
like this:

[SMB] [Short Frame]

In a row. The packets after the series of [Short Frame] packets are what
appears to be "normal" SMB traffic headed for the second client.  I don't
know enough about what I am looking at in the tcpdump log to make heads or
tails of it.

I have tried every known mtu and mss trick in the book, and so far, all to
no avial.  Does anyone have any ideas of where I should look next?

Kernel: 2.4.26 + mppe patch and pptp/gre conntrack patches
ppp: 2.4.2 (including mppe support)
pptp client: 1.4.0 - 1.5.0 rc1
iptables 1.2.9 + pptp/gre conntrack patches.

Thank you very much for your time and input.


More information about the samba mailing list