[Samba] Idealx script prerequisites?

Alex Harris aharris at digitalraver.com
Tue Jun 22 01:30:27 GMT 2004

Thanks, I've installed those and now when I run the same command 
(/usr/local/sbin/smbldap-useradd alex) I get this output:

Can't locate Crypt/SmbHash.pm in @INC (@INC contains: /usr/local/sbin/ 
/usr/lib/perl5/5.8.3/i486-linux /usr/lib/perl5/5.8.3 
/usr/lib/perl5/site_perl/5.8.3/i486-linux /usr/lib/perl5/site_perl/5.8.3 
/usr/lib/perl5/site_perl .) at /usr/local/sbin//smbldap_tools.pm line 5.
BEGIN failed--compilation aborted at /usr/local/sbin//smbldap_tools.pm 
line 5.
Compilation failed in require at /usr/local/sbin/smbldap-useradd line 32.
BEGIN failed--compilation aborted at /usr/local/sbin/smbldap-useradd 
line 32.

Any idea what module I need to install to fix that?

Board, Clint wrote:

>You need the perl LDAP libraries: http://ldap.perl.org/
>-----Original Message-----
>From: Alex Harris [mailto:aharris at digitalraver.com]
>Sent: Monday, June 21, 2004 5:02 PM
>To: samba at samba.org
>Subject: [Samba] Idealx script prerequisites? 
>    I'm trying to setup a PDC (and later on a BDC as well) using samba 
>3.02a and openLDAP 2.2.13 and I'm having some trouble with the idealx 
>scripts. When I run the command /usr/local/sbin/smbldap-useradd alex I 
>get the message:
>Can't locate object method "new" via package "Net::LDAP" (perhaps you 
>forgot to load "Net::LDAP"?) at /usr/local/sbin//smbldap_tools.pm line 176.
>What does this mean? Presumably it's looking for some perl module that 
>isn't installed, but I have no idea which one, or how to install it. Let 
>me know if there's any other information that might be pertinent, 
>thanks. :-)

More information about the samba mailing list