[Samba] PRINT$ Problems

Ryan Suarez ryan.suarez at sheridanc.on.ca
Wed Jun 16 14:04:57 GMT 2004

Try the CUPS printer drivers for windows:


And you can find your PPD here:


And here is some great documentation:


Aaron Goodman wrote:

>   Here are some more details. I am using samba 3.0.2a-Debian so that rules
>out the possibility of the bug mentioned here:
>http://lists.samba.org/archive/samba/2004-February/080294.html.  I am using
>the printer drivers from HPs website
>&cc=us&dlc=en&os=228).  I can print locally using the HPIJS drivers, how do
>I figure out what PPD?  I added the drivers using the add printer wizard in
>Windows XP.
>   Another thing, the printer is not connected directly to the machine
>running cups and samba; it is attached to a SMC router/print server.  The
>SMC router has a proprietary driver for windows and a more standard one for
>Linux so I decided to avoid that by connecting it to the Linux box and
>sharing it via samba.  The printers.conf is below.
>   I can print just fine if I disconnect a computer from the network and
>install the drivers by hand then reconnect.  If I can't get point and print
>to work is there a way to reset the drivers so it will prompt for me to find
>them locally rather than installing ones that don't work?
><DefaultPrinter HP5550>
>Info HP5550
>DeviceURI lpd://
>State Idle
>Accepting Yes
>JobSheets none none
>QuotaPeriod 0
>PageLimit 0
>KLimit 0
>---global section----
>   panic action = /usr/share/samba/panic-action %d
>   workgroup = geoduck.net
>   server string = %h server (Samba %v)
>   load printers = yes
>   printcap name = cups
>   printing = cups
>   guest account = nobody
>   log file = /var/log/samba/log.%m
>   log level = 2
>   max log size = 1000
>   syslog = 0
>   security = user
>   encrypt passwords = true
>   passdb backend = tdbsam guest
>   socket options = TCP_NODELAY
>   dns proxy = no
>   passwd program = /usr/bin/passwd %u
>   passwd chat = *Enter\snew\sUNIX\spassword:* %n\n
>*Retype\snew\sUNIX\spassword:* %n\n .
>   obey pam restrictions = yes
>-Aaron Goodman
>----- Original Message ----- 
>From: "Ryan Suarez" <ryan.suarez at sheridanc.on.ca>
>Cc: "Aaron Goodman" <aams at geoduck.net>; <samba at lists.samba.org>
>Sent: Tuesday, June 15, 2004 7:21 AM
>Subject: Re: [Samba] PRINT$ Problems
>>Oh, just saw your same error in this archive:
>>Ryan Suarez wrote:
>>>Hi Aaron,
>>>Are you using CUPS for printing?
>>>If so:
>>>What printer drivers are you using?  What PPD?  Did you use cupsaddsmb
>>>to install the printer drivers to samba?
>>>Can we see your global section for smb.conf?
>>>Aaron Goodman wrote:
>>>>I have been trying to setup point and print on a debian testing box.
>>>>I have
>>>>a HP5550 printer and am trying to install the drivers through the add
>>>>printer wizard, the drivers appeared to install fine.  Afterwards I
>>>>clicked on the printer and clicked connect, per the SAMBA howto, this
>>>>appeared to work.  When I tried to enter the properties screen of the
>>>>printer or on the share I get the following error message:
>>>>"Function address 0x60630d26 caused a protection fault. (exception code
>>>>Some or all property page(s) may not be displayed)."
>>>>After the error message comes up, the properties window does not
>>>>open.  I
>>>>cannot print either.
>>>>Here is the relavent section from my smb.conf:
>>>>  comment = All Printers
>>>>  browseable = yes
>>>>  printable = yes
>>>>  path = /tmp
>>>>  writable = yes
>>>>  create mode = 0700
>>>>  path = /etc/samba/drivers
>>>>  browsable = no
>>>>  guest ok = yes
>>>>  read only = yes
>>>>  write list = aaron root
>>>>Aaron Goodman

More information about the samba mailing list