[Samba] Samba 3.0.3 on FC2: windows machine cannot join domain

Tony Fugere tony_fugere at ncsu.edu
Mon Jun 14 13:35:21 GMT 2004


Thanks for the suggestion but after doing this I still get the same 
problem. I edited my smb.conf and the .ldif that I was importing to 
reflect the changes. Any more ideas?


Paul Gienger wrote:

>> I'm using Samba 3.0.3 on Fedora Core 2 with OpenLDAP 2.1.29 for a 
>> backend. I'm getting to typical "The user name could not be found." 
>> error upon trying to join a Windows box. I've gone through every 
>> digest on lists.samba.org and other sites and nothing has worked yet. 
>> Any suggestions:
> You must have missed the ou=Computers discussion then, it comes up 
> about every 2 weeks.
>>   ; User and Machine Account Backends
>>   ldap ssl = start_tls
>>   passdb backend = ldapsam:ldap://smbtest.soil.ncsu.edu:389
>>   ldap suffix = dc=soil,dc=ncsu,dc=edu
>>   ldap admin dn = cn=Manager,dc=soil,dc=ncsu,dc=edu
>>   ldap delete dn = no
>>   ldap user suffix = ou=People
>>   ldap group suffix = ou=Groups
>>   ldap machine suffix = ou=Computers
> change this to ou=People or do one of the workarounds people have 
> suggested, those being to reconfigure your nss library to search to a 
> point in your ldap structure that contains both ou=People and 
> ou=Computers (dc=soil,dc=ncsu,dc=edu).  I guess that's the only 
> suggested one, but I've thought about a couple others, one being to 
> make an ou=Accounts which would contain aliases to ou=People and 
> ou=Computers, but I haven't tested it yet...

Tony Fugere
tony_fugere at ncsu.edu

More information about the samba mailing list