[Samba] Problems with Samba 3.0.4 and ADS

Austin, Ben ben.austin at capgemini.com
Mon Jun 14 08:07:08 GMT 2004


I'm am trying to compile Samba 3.0.4 with ADS suuport on solaris 8. I have


To compile samba I ran:

./configure --prefix=/usr/local/samba-3.0.4 --with-configdir=/var/samba/conf
--with-lockdir=/var/samba/lock --with-private
dir=/var/samba/private --with-swatdir=/var/samba/swat
--with-logfilebase=/var/samba/log --localstatedir=/var/run --sharedstate
dir=/var/run --with-syslog --with-utmp --with-acl-support
--with-krb5=/usr/local/krb5-1.3.3 --with-winbind --with-ads

This ran successfuly and I confirmed the following within config.log:

#define HAVE_KRB5 1
#define WITH_ADS 1
#define HAVE_LDAP_H 1

Though when I run net ads testjoin it returns "ADS support not compiled in"

Anyone got any ideas??


Our name has changed.  Please update your address book to the following format: "recipient at capgemini.com".

This message contains information that may be privileged or confidential and is the property of the Capgemini Group. It is intended only for the person to whom it is addressed. If you are not the intended recipient,  you are not authorized to read, print, retain, copy, disseminate,  distribute, or use this message or any part thereof. If you receive this  message in error, please notify the sender immediately and delete all  copies of this message.

More information about the samba mailing list