[Samba] Re: Apostrophes in Windows usernames (again)

EXT-Auleta, Michael michael.auleta at boeing.com
Tue Jun 8 12:32:10 GMT 2004

We tried that also.  It didn't work either.  But since I was pointed to bug
1221, I removed the matching of an apostrophe in util_str.c (fell back to
2.2 behaviour) and that looks like it works.  My user is able to map his
shares again.

Thanks for all who helped.


-----Original Message-----
From: David Brodbeck [mailto:DavidB at mail.interclean.com]
Sent: Monday, June 07, 2004 4:23 PM
To: EXT-Auleta, Michael; samba at lists.samba.org
Subject: RE: [Samba] Re: Apostrophes in Windows usernames (again)

> -----Original Message-----
> From: EXT-Auleta, Michael [mailto:michael.auleta at boeing.com]

> I think I've narrowed down my problem, but I still don't know 
> where to fix it.  It appears that scanning the
> users.map file strips out the apostrophes and the Windows ID 
> never matches:

> The entry in the users.map file is:
> unixid = o'brienta
> so it should map.  I've tried enclosing the Windows name in 
> double quotes, but that didn't help.

What happens if you escape the apostrophe with a backslash, like this:

unixid = o\'brienta

More information about the samba mailing list