[Samba] Inactive smb mounts freeze linux 2.6.5 and samba 3.0.4

Erik Ahlner whyz at home.se
Fri Jun 4 11:43:59 GMT 2004


I am new to the list, but i've searched the archives to no avail.

A few months ago, I installed linux 2.6 and samba 3.
I use fstab to mount shares from a windows XP station. I have done this
successfully for years using 2.4 and samba2.

Mounting the remote shares work fine, for a while. After some inactivity or
a reboot of the windows XP station, mounted volumes become unusable. Not in
any ordinary sense, it just freezes the computer. This happen if i try to
reach a file on the mounted dir or just do a plain ls. I have to kill ls to
be able to go any further. Sometimes i even have to do kill -9.

If i then umount the volume and remount it, everything works fine again for
some time.

I have no idea what is the problem!

dmesg give me lines like these:
smb_add_request: request [c6e14e80, mid=1206] timed out!
smb_add_request: request [c6e14e80, mid=7] timed out!
smb_add_request: request [c3164e80, mid=1207] timed out!

Here are some infos
Slackware 9.1 installed, kernel 2.6.5 and samba 3.0.4.
I have tried with earlier versions of kernel 2.6 and samba3, but with the
same result.

This is the fstab line i use:
//winxp/c$    /mnt/winxp/c    smbfs    noauto,username=winxpuser    0    0

smb.conf looks like:
        workgroup = NORRNET
        netbios name = whyz-linux
        server string = whyz-linux
        interfaces = eth0
        security = user
        log file = /usr/local/samba/var/log.%m
        max log size = 50
        dns proxy = No
        encrypt passwords = yes
        wins server =
        hosts allow =
        socket options = TCP_NODELAY

I've been living with this for quite some time now, and it's getting
unbearable. Has anyone had the same problem?
Greatful for any advice


More information about the samba mailing list