[Samba] Locked files stay locked - copy operation from XP to Samba fails - FIXED

Bart van Dijck samba at vandijck.demon.nl
Fri Jun 4 08:01:57 GMT 2004


After trying too long I fixed the problem below by reverting to the old
3c905 NIC. Problem solved but not understood.

I had a similar 3c2000 NIC in another Samba server and it also failed to
copy a large amount (5000+) of files. So that's two completely servers
(hardware and Samba / Slackware version) having the same problem with any
number of different clients. I couldn't imagine that there is a direct
relationship somehow between the NIC and Samba, but at the moment that seems
to be the only explanation.

However: case closed.

Bart van Dijck

Bart van Dijck <> schreef:
> When trying to copy 5000+ files from a client PC to a Samba server I
> have the following problem. Halfway during the operation it hangs on
> always the same file. Windows XP (SP1) gives:
> Unable to copy file [filename]. Specified network name is no longer
> available.
>  (I had to translate this from Dutch, so it is not the exact message).
> When checking with smbstatus I get this:
> root at kylie:/etc/samba# smbstatus
> Samba version 2.2.8a
> Service      uid      gid      pid     machine
> ----------------------------------------------
> Werkmap Ba   bart     users     6706   bart     ( Thu
> May 27 13:44:01 2004
> IPC$         bart     users     6706   bart     ( Thu
> May 27 13:46:25 2004
> Locked files:
> Pid    DenyMode   Access      R/W        Oplock           Name
> --------------------------------------------------------------
> 6706   DENY_ALL   0x30196     WRONLY     NONE
> /home/bart/gobnet_bart2/images/opleidingen/fotoos/fotokl/18058k.gif
> Thu May 27 13:46:33 2004
> When I remove the offending files from the tree the rest of the files
> are copied as you would expect. I tried removing the brlock.tdb files
> (when smbd and nmbd were shut down), I then tried cleaning out the
> whole /var/cache/samba
> I set:
> oplocks = no
> kernel oplocks = no
> level2 oplocks = no
> in smb.conf
> When I check before starting the copy operation with smbstatus no
> files are locked. When starting the copy the three offending files
> are locked and stay locked.
> Could this be related to my other problem with the Realtek 8139 and
> 3com2000T? Someone suggested that the giga NIC was just too fast. I
> checked with 3com905B and C cards and they have the same problem, so
> should I revert to the old NIC in the Samba server or are there some
> tweaks I could try? Any suggestions are welcome!
> Bart van Dijck

Bart van Dijck
Sebastian Producties

Sebastian is verhuisd!
Nieuw adres per 1 mei:
Poststraat 68
5038 DH Tilburg
T (013) 5186120
F (013) 5186121
W www.sebastian.nl

More information about the samba mailing list