[Samba] Re: Apostrophes in Windows usernames (again)

EXT-Auleta, Michael michael.auleta at boeing.com
Thu Jun 3 18:28:21 GMT 2004

I think I've narrowed down my problem, but I still don't know where to fix it.  It appears that scanning the
users.map file strips out the apostrophes and the Windows ID never matches:

[2004/06/01 16:23:51, 10] lib/username.c:user_in_list(521)
  user_in_list: checking user o'brienta in list
[2004/06/01 16:23:51, 10] lib/username.c:user_in_list(525)
  user_in_list: checking user |o'brienta| against |obrienta|
[2004/06/01 16:23:51, 5] auth/auth_util.c:make_user_info_map(216)
  make_user_info_map: Mapping user [XX]\[o'brienta] from workstation [workstation]

The entry in the users.map file is:

unixid = o'brienta

so it should map.  I've tried enclosing the Windows name in double quotes, but that didn't help.

This worked in 2.2.2 on Solaris 8, but we're now running 3.0.2a on Solaris 8 doing domain authentication.
There are no local Samba accounts.

I've applied the changes that were suggested on Mon Dec 8 21:39:52 GMT 2003 to add the apostrophe
to the list of SAFE_NETBIOS_CHARACTERS and to smbd/password.c.

Any ideas?


Mike Auleta
Boeing IDS, Philadelphia

Who's the more foolish, the fool or the fool who's following him?

More information about the samba mailing list