[Samba] Force user

Robert Sossomon robert at gcnorris.com
Thu Jun 3 18:15:29 GMT 2004

This has never worked for me. Files created inherit the group of the
directory, but not the owner. I have even followed, line for line, the
sequence on that page as follows:

# chmod 6775 /foodbar
$ ls -al /foodbar/..

You should see:

drwsrwsr-x  2 jack  engr    48 2003-02-04 09:55 foodbar


Now type:

$ su - jill
$ cd /foodbar
$ touch Afile
$ ls -al

You should see that the file Afile created by Jill will have ownership
and permissions of Jack, as follows:

-rw-r--r--  1 jack  engr     0 2003-02-04 09:57 Afile

That all works right up until the last line, where I see the file owner
is jill, not jack. Maybe I've misunderstood this, 


It looks to me that the owner and group are still the same, there is no
mention of jill anywhere.  If you mean the permissions are wrong, then
you need to look at your smb.conf file again to make sure you set the
permissions flag correctly.

What is your smb.conf for this section?


More information about the samba mailing list