[Samba] using VSS on a samba server - no smb locks ?

Nir Livni nir.livni at cyber-ark.com
Sat Jan 31 11:37:14 GMT 2004

----- Original Message ----- 
From: "Jeremy Allison" <jra at samba.org>
To: "Nir Livni" <nir.livni at cyber-ark.com>
Cc: "Jeremy Allison" <jra at samba.org>; <samba at lists.samba.org>
Sent: Friday, January 30, 2004 10:25 PM
Subject: Re: [Samba] using VSS on a samba server - no smb locks ?

> On Fri, Jan 30, 2004 at 10:13:55PM +0200, Nir Livni wrote:
> >
> > Well, actually all oplocks where turned off in my smb.conf.
> > I tried to checkin and checkout some files with few users, but no
> > Using samba-2.2.8a (I forgot to mention)
> No lockingX calls ? There are several possible locking calls. Or
> maybe the app does some higher level synchronisation.
VSS has a "lock_mode" parameter, that has two modes. Native / FileLock.
Both of them achieve the same result - locking database files for

The "testlock" utility was ment to help administrators to deteremine whether
their file system supports the Native lock mode. If the test fails - they
have to use FileLock lockmode.

Testlock generates a lockingX transaction (are there any other smb locking
transactions ?), which means that the lockingX is the way to get a native
lock in VSS.
FileLock lock mode simply creates files (.lck) in the "locks" folder of the
database, to mark locks. When the file is deleted - lock is removed.

I am not saying that there is a samba problem here.
I just think that the fact that testlock.exe uses lockingX, but the clients
of VSS do not use lockingX, show that there may be a configuration problem,
which I am trying to solve.


> Jeremy.

More information about the samba mailing list