[Samba] Access97, in house VB6 app, terrible performance

Tim Smith tims at cqpl.com.au
Tue Jan 27 23:49:00 GMT 2004

hello everyone I am running suse9.0 with samba 2.2.8 kernel 2.4.23, the 
app is in vb6 using the vb jetengine to access access97 databases, 
roughly 15 of them all between 200 - 900 megs in size, all on the same 
shared drive.
This arrangement works well on our NT4 server. but when we try to use 
linux/samba we find read/writing is incrediably slow. as an example our 
standard test on NT4 takes 4 -5 seconds to run. Now, with 6 workstations 
connected under samba this test also takes 4 - 5 seconds, BUT as soon as 
the entire lab is connected which is roughly 30 - 40 pc's, that time 
jumps to 20 - 30 seconds.
Now here is what we have tried:
standard samba install, oplocks are at defaults. very very slow performance.
we have also tried vetto oplocks, seemed to have no affect.
after much fiddling with socket options, log levels and much reading on 
how oplocks work we discovered if "fake oplocks = yes" was set our 
performance issues vanished. however, we then found we had troubles with 
deleteing a record in a database which was open. in our environment 
databases are constantly open so this is a big problem.
our last attempt ( this morning ) was using locking = yes, which with 6 
workstations connected appeared to be perfect. but alas it was also slow.
here is our current configuration file.

   workgroup = laboratory
   socket options = SO_KEEPALIVE TCP_NODELAY SO_SNDBUF=8192 
   lock spin time = 15
   lock spin count = 100
   log level = 1
   max log size = 50
   level2 oplocks = no
   oplocks = no
   locking = yes
   getwd cache = yes
   os level = 2
   time server = Yes
   unix extensions = Yes
   encrypt passwords = yes
   map to guest = Bad User
   printing = CUPS
   printcap name = CUPS
   wins support = yes
;   wins server =
   server string = Pathware
   add user script =
   domain master = false
   domain logons = no
   local master = no
   preferred master = auto
;;   ldap server =

this is also how our shares are setup

   comment = PathWare Data
   path = /raid/share_d
   force directory mode = 0777
   force create mode = 0777
   browseable = yes
   read only = no
   guest ok = no
   printable = no

please fire away with questions and suggestions, if i havent made 
something clear i apologise.
I'm all ears.

More information about the samba mailing list