[Samba] after switching to ldap, cannot net groupmap stuff

John H. mrmailer at myway.com
Mon Jan 26 08:36:13 GMT 2004

btw, i tried removing dc=INTRANET from user,group, and machine suffix, same error

 --- On Mon 01/26, John H. < mrmailer at myway.com > wrote:
From: John H. [mailto: mrmailer at myway.com]
To: samba at lists.samba.org
Date: Mon, 26 Jan 2004 03:28:29 -0500 (EST)
Subject: Re: [Samba] after switching to ldap, cannot net groupmap stuff

<br>#ldap<br>        passdb backend = ldapsam:ldap://<br>        ldap suffix = "dc=INTRANET"<br>        ldap machine suffix = ou=People,dc=INTRANET<br>        ldap passwd sync = yes<br>        ldap user suffix = ou=People,dc=INTRANET<br>        ldap group suffix = ou=Group,dc=INTRANET<br>        ldap admin dn = "cn=Manager,dc=INTRANET"<br>        ldap ssl = no<br>        idmap backend = ldapsam:ldapsam://<br>        passwd chat debug = Yes<br>        passwd program =/usr/local/sbin/smbldap-passwd -o %u<br>        passwd chat = *new*password* %n\n *new*password:* %n\ *successfully*<br>        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192<br>        add machine script = /usr/local/sbin/smbldap-useradd -w %m<br>add user script = /usr/local/sbin/smbldap-useradd -a %u<br>        delete user script = /usr/local/sbin/smbldap-userdel %u<br>        add group script = /usr/local/sbin/smbldap-groupadd %g<br>        delete group script = /usr/local/sbin/smbldap-groupdel %g<br>        add user to group script = /usr/local/sbin/smbldap-groupmod -m %u %g<br>        delete user from group script = /usr/local/sbin/smbldap-groupmod -x %u $        set primary group script = /usr/local/sbin/smbldap-usermod -G %g %u<br><br><br><br><br><br> --- On Mon 01/26, Andrew Bartlett < abartlet at samba.org > wrote:<br>From: Andrew Bartlett [mailto: abartlet at samba.org]<br>To: mrmailer at myway.com<br>     Cc: samba at lists.samba.org<br>Date: Mon, 26 Jan 2004 19:23:25 +1100<br>Subject: Re: [Samba] after switching to ldap, cannot net groupmap stuff<br><br>On Mon, 2004-01-26 at 18:48, John H. wrote:<br>> ok, i switched to ldap and my users can login and what not, but i cannot use net groupmap for groups anymore.  everything else seems to work ok?  if i cannot map groups like this(for instance, unix users group to Domain Power Users) anymore, how do i do it?<br>> <br>> If i do net groupmap list, I get<br>> <br>>  net groupmap list<br>> [2004/01/26 01:46:44, 0] passdb/pdb_ldap.c:ldapsam_setsamgrent(2048)<br>>   ldapsam_setsamgrent: LDAP search failed: Invalid DN syntax<br><br>What is in your smb.conf for ldap settings?<br><br>Andrew Bartlett<br><br>-- <br>Andrew Bartlett                                 abartlet at pcug.org.au<br>Manager, Authentication Subsystems, Samba Team  abartlet at samba.org<br>Student Network Administrator, Hawker College   abartlet at hawkerc.net<br>http://samba.org     http://build.samba.org     http://hawkerc.net<br>Attachment: signature.asc  (0.19KB)<br><br><br>_______________________________________________<br>No banners. No pop-ups. No kidding.<br>Introducing My Way - http://www.myway.com<br>-- <br>To unsubscribe from this list go to the following URL and read the<br>instructions:  http://lists.samba.org/mailman/listinfo/samba<br>

No banners. No pop-ups. No kidding.
Introducing My Way - http://www.myway.com

More information about the samba mailing list