[Samba] Connection refused, access denied (Windows XP trying to connect on samba's shared printer)

Craig White craigwhite at azapple.com
Sun Jan 25 02:17:55 GMT 2004

On Sat, 2004-01-24 at 17:30, Mark Hougaard wrote:
> Jonny,
> Did you ever get your shared printer issue resolved? If so, how? I'm 
> having exactly the
> same problem and I didn't see that anyone responded to your request for 
> help on the
> lists.samba.org group.
> My setup and problem is pretty much the same as yours was Win XP pro can 
> see printer
> share on Linux  RH9.0 (kernel 2.4.20), but cannot get access once the 
> drivers are configured.
> Any help would be greatly appreciated.
I had a bunch of grief setting up HP Laser printers on AS 3 which is
virtually identical to RH 9. The first one worked, the second one didn't
and then the first one didn't work anymore. Spent a lot of hours on this
and finally got it working - here's how I did it, this might not be the
'recommended' way but it worked for me.

The redhat-config-printer tool just didn't seem to cut it. I deleted all
the printers created by that tool. I did have the postscript.ppd file
for each printer which copied up via the APW as described in the how-to.
I put a copy of the ppds in /usr/share/cups/model/ppd subdirectory.

I then used the cups web tool... http://localhost:631  (if you are
accessing from a different computer, watch the firewall settings).

>From this tool, I created the printers and then when I was all done, I
restarted smbd/nmbd (service smb restart)

Bang - they worked. 

Note - if that was your smb.conf that was originally attached, when
using cups, I don't think that you want any 'print commands' and you
will probably want a PRINT$ share - see the how-to. I would also
recommend using encrypt passwords = yes and wins support = yes



More information about the samba mailing list