[Samba] cannot access umlaut file names with Samba3

Wolfgang Riedmann wolfgang at riedmann.it
Wed Jan 21 11:51:36 GMT 2004


I' m not very happy with Samba3 as I have very heavy problems with 
filenames containing umlaut characters.

I have installed a new Debian 3 server for a client with Samba 3.0.1 
(Debian packages), and copied over the data from a SuSE 6.4 (Samba 
2.2.8a) system by mounting the hard disk into the new system.

Now, I cannot access the files and directories with umlaut characters 
anymore. I understand that Samba3 talks Unicode, but it should be 
possible to access the files to let rename them.

The only thing I can do is to rename file file with a terminal 
access. And there seem to be differences between Windows 98 and 
Windows 2000 clients. 

I have a file called "Lärm.MDB" (I cannot change the name because 
it's hard coded in an Access program). I have renamed this file with 
my shell access to "Laerm.MDB", and then tried to rename it to 
"Lärm.MDB" again with a Windows 98 workstation. This rename was 
successful, but the access was denied after. Only a rename made on a 
W2K machine let access this file from the Win98 machine.

IMHO it would be very important to have a "compatibility mode" that 
works as Samba 2. I have tried different settings between unix 
charset and dos charset with CP850, ASCII and UTF-8, but none solved 
my problem.

Thank you in advance for any help!


-- Wolfgang Riedmann
-- Individuelle EDV-Lösungen - Soluzioni informatiche personalizzate
-- I-39012 Meran, V. Laurin-Str. 2d
-- http://www.riedmann.it - wolfgang at riedmann.it

More information about the samba mailing list