[Samba] smbldap-tools 8.3 populate errors

Manfred Odenstein manfred.odenstein at chello.at
Mon Jan 19 09:35:10 GMT 2004

Am Sonntag, 18. Januar 2004 10:55 schrieb Jérôme Tournier:
> > My system is now runnung, but I think there are some bugs in the populate
> > script, e.g. the SID of the Administrator account should end with -500 as
> > I know, because it's predefinded. Any comment from the author ???
> 500 is the well-known RID for the domain administrator, not for
> the administrator account, am i wrong ?

AFAIK, if you operate as a PDC it have to be 500, because a NT PDC hasn't its 
own user-database, it uses the domain-database, so the administrator is the 
same as the Domain Adminstrator, maybe I'm wrong, but ...

> > I've also changed the gidNumber and uidNumber of the guest account and
> > "Domain Guest" group to the default values of my system (SuSE9)
> >
> > after this all worked correctly except some log-entries .
> > "Failed to open group mapping database" ....
> > and
> > "failed to decode PDU"
> Do you always have this error messages ? With every scripts ?
> Thanks for your report !
> --
> Jérôme

I've not tested this with other scripts (e.g. 0.8.2), because til I've tried 
0.8.3 I didn't noticed that if I want to add a user, the given script at "add 
user script"  isn't called with smbpasswd -a, if I added a user with "net 
user add", the given script was called (I've written a dummy script with 
syslog output), and the I've tried 0.8.3 and it worked. but I will give 0.8.2 
a try if you want


More information about the samba mailing list