[Samba] weird samba bug? some files from shares sometimes missing..

Michael Pflüger empx at gmx.de
Tue Jan 6 13:50:39 GMT 2004

Hello, well, i have a weird problem:
i mounted a share, shared on winxp, on my gentoo linux box via mount -t 
smbfs.. everything seems to work - seems. When i started to backup files 
with rdiff-backup, i noticed that it reported about new and deleted 
files, yet those were never deleted and are still present on the source 
share on the windows machine. I thought it might be a bug in 
rdiff-backup, yet that is not the case, ls /share | wc reports very 
often 509, sometimes even 508, 507 and 506 files, even though there are 
510 files in the directory on the share.
Ok I thought, maybe a bug in a recent samba version or something - yet 
ive tried it on two gentoo machines, one using kernel 2.6/samba 
3.0.1,gcc 3.3.2, and the other one kernel 2.4.23/samba 2.2.8a/gcc 3.2.3 
- and ive also tried it with another windows box, the result is the 
same. When i access the share via a windows box, it works ok and always 
shows 510 files.
Each backup process, which checked about 40.000 files, only a few files 
were missing, so when you only check folders with only a few files you 
might not notice this at all..

I really hope someone can help me here, a backup with missing files aint 
really nice

More information about the samba mailing list